#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|.*"
Local $sString = "email1@pochta.ru|Ян|По|2|1965-10-06|" & @CRLF & _
"email2@pochta.ru|У Хи|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл." & @CRLF & _
"bagirova_1957@mail.ru|sofiya|bagirova|2|1957-07-11|Азия, Узбекистан, Самаркандская область, Самарканд|" & @CRLF & _
"bagiraz@mail.ru|Эллина|2017|2|1970-03-04||" & @CRLF & _
"bagirfaz@mail.ru|Анна|Говнецова|2|1970-03-04||"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")