using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|.*";
string input = @"email1@pochta.ru|Ян|По|2|1965-10-06|
email2@pochta.ru|У Хи|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.
bagirova_1957@mail.ru|sofiya|bagirova|2|1957-07-11|Азия, Узбекистан, Самаркандская область, Самарканд|
bagiraz@mail.ru|Эллина|2017|2|1970-03-04||
bagirfaz@mail.ru|Анна|Говнецова|2|1970-03-04||";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}