import Foundation
let pattern = #"^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
email1@pochta.ru|Ян|По|2|1965-10-06|
email2@pochta.ru|У Хи|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.
bagirova_1957@mail.ru|sofiya|bagirova|2|1957-07-11|Азия, Узбекистан, Самаркандская область, Самарканд|
bagiraz@mail.ru|Эллина|2017|2|1970-03-04||
bagirfaz@mail.ru|Анна|Говнецова|2|1970-03-04||
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)