package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|.*`)
var str = `email1@pochta.ru|Ян|По|2|1965-10-06|
email2@pochta.ru|У Хи|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.
bagirova_1957@mail.ru|sofiya|bagirova|2|1957-07-11|Азия, Узбекистан, Самаркандская область, Самарканд|
bagiraz@mail.ru|Эллина|2017|2|1970-03-04||
bagirfaz@mail.ru|Анна|Говнецова|2|1970-03-04||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}