#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:x{|(?<!^)\G)[^\s}]*\K\s+(?!})"
Local $sString = "x{Test test} test test x{Test test test } test {Test test}"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)