use strict;
my $str = 'x{Test test} test test x{Test test test } test {Test test}';
my $regex = qr/(?:x{|(?<!^)\G)[^\s}]*\K\s+(?!})/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";