$re = '/(?:x{|(?<!^)\G)[^\s}]*\K\s+(?!})/m';
$str = 'x{Test test} test test x{Test test test } test {Test test}';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;