import Foundation
let pattern = #"(?:x{|(?<!^)\G)[^\s}]*\K\s+(?!})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"x{Test test} test test x{Test test test } test {Test test}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)