import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:(?:(?:var|let)[ \\t]+)?([\\w.\\-]+)[ \\t]*[:=]|[(!])[ \\t]*)function(?:[ \\t]+([\\w.\\-]+))?[ \\t]*\\([^)]*\\)";
final String string = "!function(){}() // test1\n"
+ "!function test2(){}() // test2\n"
+ "(function(){})() // test3\n"
+ "(function test4(){})() // test4\n"
+ "test5 = function(){} // test5\n"
+ "test6 = function _test6(){} // test6\n"
+ "let test7 = function(){} // test7\n"
+ "let test8 = function _test8(){} // test8\n"
+ "var test9 = function(){} // test8\n"
+ "var test10 = function _test10(){} // test10\n"
+ "myfunc(function(){}) // test11\n"
+ "myfunc(function test12(){}) // test12\n"
+ "let myobj = {test13 : function(){}} // test13\n"
+ "let myobj = {test14 : function _test14(){}} // test14\n"
+ "var myobj = {test15 : function(){}} // test15\n"
+ "var myobj = {test16 : function _test16(){}} // test16\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}