import re
regex = re.compile(r"(?:(?:(?:(?:var|let)[ \t]+)?([\w.\-]+)[ \t]*[:=]|[(!])[ \t]*)function(?:[ \t]+([\w.\-]+))?[ \t]*\([^)]*\)", flags=re.MULTILINE)
test_str = ("!function(){}() // test1\n"
"!function test2(){}() // test2\n"
"(function(){})() // test3\n"
"(function test4(){})() // test4\n"
"test5 = function(){} // test5\n"
"test6 = function _test6(){} // test6\n"
"let test7 = function(){} // test7\n"
"let test8 = function _test8(){} // test8\n"
"var test9 = function(){} // test8\n"
"var test10 = function _test10(){} // test10\n"
"myfunc(function(){}) // test11\n"
"myfunc(function test12(){}) // test12\n"
"let myobj = {test13 : function(){}} // test13\n"
"let myobj = {test14 : function _test14(){}} // test14\n"
"var myobj = {test15 : function(){}} // test15\n"
"var myobj = {test16 : function _test16(){}} // test16\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")