using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:<:]]lms.com[[:>:]]";
string input = @"lms.com
live.lms.com
live-lms.com
cssslms.com
lmsccc.com
lms.com.ph
lms.com.edu
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}