package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[[:<:]]lms.com[[:>:]]`)
var str = `lms.com
live.lms.com
live-lms.com
cssslms.com
lmsccc.com
lms.com.ph
lms.com.edu
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}