re = /[[:<:]]lms.com[[:>:]]/mi
str = 'lms.com
live.lms.com
live-lms.com
cssslms.com
lmsccc.com
lms.com.ph
lms.com.edu
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end