$re = '/[[:<:]]lms.com[[:>:]]/mi';
$str = 'lms.com
live.lms.com
live-lms.com
cssslms.com
lmsccc.com
lms.com.ph
lms.com.edu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);