#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s(?:low|high)\s)?(?:\S+\s+and\s)?\S+[ \t]+(?:stress|deficiency|limiting)"
Local $sString = "salt and water stress" & @CRLF & _
"photo-oxidative stress" & @CRLF & _
"salinity and high light stress" & @CRLF & _
"low-temperature stress" & @CRLF & _
"Cd stress" & @CRLF & _
"Cu deficiency" & @CRLF & _
"N deficiency" & @CRLF & _
"IMI stress" & @CRLF & _
"" & @CRLF & _
"no match:" & @CRLF & _
"" & @CRLF & _
"stress" & @CRLF & _
"deficiency" & @CRLF & _
"limiting" & @CRLF & _
"temperature and water" & @CRLF & _
"low" & @CRLF & _
"high" & @CRLF & _
"water and salt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")