# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s(?:low|high)\s)?(?:\S+\s+and\s)?\S+[ \t]+(?:stress|deficiency|limiting)"
test_str = ("salt and water stress\n"
"photo-oxidative stress\n"
"salinity and high light stress\n"
"low-temperature stress\n"
"Cd stress\n"
"Cu deficiency\n"
"N deficiency\n"
"IMI stress\n\n"
"no match:\n\n"
"stress\n"
"deficiency\n"
"limiting\n"
"temperature and water\n"
"low\n"
"high\n"
"water and salt")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.