import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s(?:low|high)\\s)?(?:\\S+\\s+and\\s)?\\S+[ \\t]+(?:stress|deficiency|limiting)";
final String string = "salt and water stress\n"
+ "photo-oxidative stress\n"
+ "salinity and high light stress\n"
+ "low-temperature stress\n"
+ "Cd stress\n"
+ "Cu deficiency\n"
+ "N deficiency\n"
+ "IMI stress\n\n"
+ "no match:\n\n"
+ "stress\n"
+ "deficiency\n"
+ "limiting\n"
+ "temperature and water\n"
+ "low\n"
+ "high\n"
+ "water and salt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}