using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?!(?:marker1|marker2)\])|(?<!\[(?:marker1|marker2))\]";
string input = @"text here [incorrect_marker] - invalid marker error
text here [ more text here - invalid use of square bracket
text here ] more text here - invalid use of square bracket
text here [[marker1] but too many square brackets";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}