const regex = /\[(?!(?:marker1|marker2)\])|(?<!\[(?:marker1|marker2))\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?!(?:marker1|marker2)\\])|(?<!\\[(?:marker1|marker2))\\]', 'gm')
const str = `text here [incorrect_marker] - invalid marker error
text here [ more text here - invalid use of square bracket
text here ] more text here - invalid use of square bracket
text here [[marker1] but too many square brackets`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}