import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?!(?:marker1|marker2)\\])|(?<!\\[(?:marker1|marker2))\\]";
final String string = "text here [incorrect_marker] - invalid marker error\n\n"
+ "text here [ more text here - invalid use of square bracket\n\n"
+ "text here ] more text here - invalid use of square bracket\n\n"
+ "text here [[marker1] but too many square brackets";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}