$re = '/\[(?!(?:marker1|marker2)\])|(?<!\[(?:marker1|marker2))\]/m';
$str = 'text here [incorrect_marker] - invalid marker error
text here [ more text here - invalid use of square bracket
text here ] more text here - invalid use of square bracket
text here [[marker1] but too many square brackets';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);