use strict;
my $str = '$$$$$$$$$$$$$$$$$$$$
aabb
th@@@@@@eemo@@@@@@ey
Cash$$$$$$Ca$$$$$$sh
validticketnomatch:(
$$$$$$$$$$##########
$$$$$$$$##$$$$$$$$$$';
my $regex = qr/(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\k<ch>{6,}).*(?<=.{10})\k<match>.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}