$re = '/(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\k<ch>{6,}).*(?<=.{10})\k<match>.*/m';
$str = '$$$$$$$$$$$$$$$$$$$$
aabb
th@@@@@@eemo@@@@@@ey
Cash$$$$$$Ca$$$$$$sh
validticketnomatch:(
$$$$$$$$$$##########
$$$$$$$$##$$$$$$$$$$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);