using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/api\/savedsearches\/[0-9a-z]{24}\/on";
string input = @"/api/savedsearches/5a6f390be4b01fbf020780c6/on";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}