$re = '/\/api\/savedsearches\/[0-9a-z]{24}\/on/';
$str = '/api/savedsearches/5a6f390be4b01fbf020780c6/on';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);