re = /\/api\/savedsearches\/[0-9a-z]{24}\/on/
str = '/api/savedsearches/5a6f390be4b01fbf020780c6/on'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end