// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/api\/savedsearches\/[0-9a-z]{24}\/on").unwrap();
let string = "/api/savedsearches/5a6f390be4b01fbf020780c6/on";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}