#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)\.\s"([a-zA-Z ]+)"\s[a-zA-Z \.]+\s([a-zA-Z, \.]+)\s([\d:]+)"
Local $sString = "1. "Anbae Anbae" Vairamuthu Hariharan, K. S. Chitra 5:10" & @CRLF & _
"2. "I Love You" Vairamuthu Nandini Srikar, KK, Ajith Kumar 4:55" & @CRLF & _
"3. "Nathi Enge Valaiyum" Vairamuthu Ghanshyam Vaswani 4:37" & @CRLF & _
"4. "Nothing Nothing" Vairamuthu Harini 4:44" & @CRLF & _
"5. "Poovukellam Siragu" Vairamuthu Srinivas, KK, Harini 5:27" & @CRLF & _
"6. "Vannakili SolKonda" Vairamuthu Gopal Rao, Harini, Chorus 4:38"
Local $sSubst = "\1 \2 - \3 \4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)