import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\.\\s\"([a-zA-Z ]+)\"\\s[a-zA-Z \\.]+\\s([a-zA-Z, \\.]+)\\s([\\d:]+)";
final String string = "1. \"Anbae Anbae\" Vairamuthu Hariharan, K. S. Chitra 5:10\n"
+ "2. \"I Love You\" Vairamuthu Nandini Srikar, KK, Ajith Kumar 4:55\n"
+ "3. \"Nathi Enge Valaiyum\" Vairamuthu Ghanshyam Vaswani 4:37\n"
+ "4. \"Nothing Nothing\" Vairamuthu Harini 4:44\n"
+ "5. \"Poovukellam Siragu\" Vairamuthu Srinivas, KK, Harini 5:27\n"
+ "6. \"Vannakili SolKonda\" Vairamuthu Gopal Rao, Harini, Chorus 4:38";
final String subst = "\\1 \\2 - \\3 \\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}