import Foundation
let pattern = #"(\d+)\.\s"([a-zA-Z ]+)"\s[a-zA-Z \.]+\s([a-zA-Z, \.]+)\s([\d:]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. "Anbae Anbae" Vairamuthu Hariharan, K. S. Chitra 5:10
2. "I Love You" Vairamuthu Nandini Srikar, KK, Ajith Kumar 4:55
3. "Nathi Enge Valaiyum" Vairamuthu Ghanshyam Vaswani 4:37
4. "Nothing Nothing" Vairamuthu Harini 4:44
5. "Poovukellam Siragu" Vairamuthu Srinivas, KK, Harini 5:27
6. "Vannakili SolKonda" Vairamuthu Gopal Rao, Harini, Chorus 4:38
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2 - \3 \4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)