using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^v(?<major>\d+)(\.(?<minor>\d+))?(\.(?<patch>\d+))\+k3s?((?<build>\d+))$";
string input = @"v1.21.6+k3s1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}