$re = '/^v(?<major>\d+)(\.(?<minor>\d+))?(\.(?<patch>\d+))\+k3s?((?<build>\d+))$/m';
$str = 'v1.21.6+k3s1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);