const regex = /^v(?<major>\d+)(\.(?<minor>\d+))?(\.(?<patch>\d+))\+k3s?((?<build>\d+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^v(?<major>\\d+)(\\.(?<minor>\\d+))?(\\.(?<patch>\\d+))\\+k3s?((?<build>\\d+))$', 'gm')
const str = `v1.21.6+k3s1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}