package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^v(?<major>\d+)(\.(?<minor>\d+))?(\.(?<patch>\d+))\+k3s?((?<build>\d+))$`)
var str = `v1.21.6+k3s1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}