using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nametovalue\(([a-zA-Z]+),";
string input = @"select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}