$re = '/nametovalue\(([a-zA-Z]+),/m';
$str = 'select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate(\'_\', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate(\'_\', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);