// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)nametovalue\(([a-zA-Z]+),").unwrap();
let string = "select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}