const regex = /nametovalue\(([a-zA-Z]+),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('nametovalue\\(([a-zA-Z]+),', 'gm')
const str = `select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value select hql.nametovalue(WorkflowReasonType, substring(rs.ResourceName,locate('_', rs.ResourceName)+1)) as Code, rs.ResourceValue as Value`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}