#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.)(?:\2(?:(?!\1)(?1))*)*)$"
Local $sString = "a" & @CRLF & _
"aa" & @CRLF & _
"ab" & @CRLF & _
"abc" & @CRLF & _
"aabb" & @CRLF & _
"aabbaa" & @CRLF & _
"aabbcc" & @CRLF & _
"aaabbb" & @CRLF & _
"aaabbbccc" & @CRLF & _
"wwxxyyzzww" & @CRLF & _
"bbbaaa" & @CRLF & _
"" & @CRLF & _
"abb" & @CRLF & _
"aab" & @CRLF & _
"xyyz" & @CRLF & _
"foof" & @CRLF & _
"abbab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")