import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.)(?:\\2(?:(?!\\1)(?1))*)*)$";
final String string = "a\n"
+ "aa\n"
+ "ab\n"
+ "abc\n"
+ "aabb\n"
+ "aabbaa\n"
+ "aabbcc\n"
+ "aaabbb\n"
+ "aaabbbccc\n"
+ "wwxxyyzzww\n"
+ "bbbaaa\n\n"
+ "abb\n"
+ "aab\n"
+ "xyyz\n"
+ "foof\n"
+ "abbab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}