re = /^((.)(?:\2(?:(?!\1)(?1))*)*)$/m
str = 'a
aa
ab
abc
aabb
aabbaa
aabbcc
aaabbb
aaabbbccc
wwxxyyzzww
bbbaaa
abb
aab
xyyz
foof
abbab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end