$re = '/^((.)(?:\2(?:(?!\1)(?1))*)*)$/m';
$str = 'a
aa
ab
abc
aabb
aabbaa
aabbcc
aaabbb
aaabbbccc
wwxxyyzzww
bbbaaa
abb
aab
xyyz
foof
abbab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);