using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d|(a-f)]{2}:){5}[\d|(a-f)]{2}";
string input = @"Текст с 1 цифрой и 00:26:57:00:1f:02.мак-адресом 00:26:57:00:f1:02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}