const regex = /([\d|(a-f)]{2}:){5}[\d|(a-f)]{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d|(a-f)]{2}:){5}[\\d|(a-f)]{2}', 'gm')
const str = `Текст с 1 цифрой и 00:26:57:00:1f:02.мак-адресом 00:26:57:00:f1:02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}