$re = '/([\d|(a-f)]{2}:){5}[\d|(a-f)]{2}/m';
$str = 'Текст с 1 цифрой и 00:26:57:00:1f:02.мак-адресом 00:26:57:00:f1:02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);