import re
regex = re.compile(r"([\d|(a-f)]{2}:){5}[\d|(a-f)]{2}", flags=re.MULTILINE)
test_str = "Текст с 1 цифрой и 00:26:57:00:1f:02.мак-адресом 00:26:57:00:f1:02"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")