#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z][a-z]*(?:\s[a-z]*)*):(.*?)(?=$|[A-Z][a-z]*(?:\s[a-z]*)*:)"
Local $sString = "Weight: About 17 lbs Color: Black Load capacity: 263 lbs Tested for: 120-150 kg (263-330 lbs) dynamic state Overall dimension: 22.5" x 21.5" x 35"- 39" (L x W x H) Backrest size:17.5" x 19" Seat size:17.5" x 17.5" Adjustable chair seat: 18"-22"" & @CRLF & _
"Как я понимаю одну пару: [слово с большой буквы(или слово с большой и несколько с маленькой)][:][что-то до следующего такого же ключа:] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")