using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z][a-z]*(?:\s[a-z]*)*):(.*?)(?=$|[A-Z][a-z]*(?:\s[a-z]*)*:)";
string input = @"Weight: About 17 lbs Color: Black Load capacity: 263 lbs Tested for: 120-150 kg (263-330 lbs) dynamic state Overall dimension: 22.5"" x 21.5"" x 35""- 39"" (L x W x H) Backrest size:17.5"" x 19"" Seat size:17.5"" x 17.5"" Adjustable chair seat: 18""-22""
Как я понимаю одну пару: [слово с большой буквы(или слово с большой и несколько с маленькой)][:][что-то до следующего такого же ключа:] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}