import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z]*(?:\\s[a-z]*)*):(.*?)(?=$|[A-Z][a-z]*(?:\\s[a-z]*)*:)";
final String string = "Weight: About 17 lbs Color: Black Load capacity: 263 lbs Tested for: 120-150 kg (263-330 lbs) dynamic state Overall dimension: 22.5\" x 21.5\" x 35\"- 39\" (L x W x H) Backrest size:17.5\" x 19\" Seat size:17.5\" x 17.5\" Adjustable chair seat: 18\"-22\"\n"
+ "Как я понимаю одну пару: [слово с большой буквы(или слово с большой и несколько с маленькой)][:][что-то до следующего такого же ключа:] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}