$re = '~([A-Z][a-z]*(?:\s[a-z]*)*):(.*?)(?=$|[A-Z][a-z]*(?:\s[a-z]*)*:)~m';
$str = 'Weight: About 17 lbs Color: Black Load capacity: 263 lbs Tested for: 120-150 kg (263-330 lbs) dynamic state Overall dimension: 22.5" x 21.5" x 35"- 39" (L x W x H) Backrest size:17.5" x 19" Seat size:17.5" x 17.5" Adjustable chair seat: 18"-22"
Как я понимаю одну пару: [слово с большой буквы(или слово с большой и несколько с маленькой)][:][что-то до следующего такого же ключа:] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);